Gestion des collections

Cette partie de la documentation concerne tout ce qui touche à la gestion des collections.

Ajouter ou supprimer des éléments

Pour ajouter un nouvel élément, il est possible d’utiliser le premier bouton de la barre d’outils ou bien l’élément correspondant dans le menu Fichier.

Alors apparaît dans la liste un nouvel élément et la partie droite ne contient aucune information.

L’utilisateur peut alors remplir tous les champs, ou utiliser la fonctionnalité décrite plus bas. Les champs pourront ensuite être modifiés soit directement dans les informations de l’élément si le mode d’affichage le permet (voir Affichage). Soit dans la fenêtre qui s’ouvre lorsque l’on double-clique sur un élément dans la liste.

Pour changer l’image associée, s’il y en a, il faudra cliquer dessus ce qui permettra ensuite de choisir un fichier. Un clic droit montre un menu qui permet en outre d’utiliser l’image par défaut plutôt que celle courante ou d’afficher l’image dans sa taille réelle. C’est d’ailleurs cette dernière possibilité qui sera parfois le choix par défaut pour certaines collections. Le changement d’image se fera alors par le clic droit.

Pour supprimer un élément, il suffit de l’afficher puis de cliquer sur le bouton Supprimer présent en bas à droite. Cette suppression ne sera prise en compte qu’une fois la liste sauvegardée.

Supprimer l'élément courant

La même action peut aussi être réalisée avec le menu contextuel qui apparait en faisant un clic droit sur un élément de la liste, ou en utilisant l’élément correspondant dans le menu Edition.

Une confirmation sera demandée avant la suppression.

Confirmation demandée à l'utilisateur

La fenêtre contient une case à cocher permettant d’éviter que ce soit demandé à nouveau. Pour réactiver cette notification, il faudra aller dans l’onglet Options des Préférences.

Récupération automatique des informations

Il existe une possibilité pour simplifier le remplissage des informations. Il suffit de saisir le nom dans la zone prévue tout en haut de la partie droite de la fenêtre (elle sera sélectionné après la création d’un nouvel élément) puis de presser le bouton Télécharger ou d’appuyer sur la touche Entrée du clavier. Le comportement de GCstar va alors être différent selon ce que l’utilisateur a indiqué dans ses préférences (plus d’information dans le chapitre Internet). Il y a trois possibilités principales.

L’utilisateur peut avoir choisi de spécifier le site lors de chaque recherche. Une fenêtre ressemblant à ceci apparaît alors :

Sélection du site de recherche

La case à cocher en bas de la fenêtre permet de mémoriser le choix de l’utilisateur. Cela correspond au deuxième type de recherche pour lequel un seul site est utilisé sans demander de le spécifier.

Il y a enfin un autre type de recherche, plus automatisé. L’utilisateur définit au préalable une liste de sites, et ce sont eux qui seront utilisés. Si rien n’est trouvé sur le premier site, la recherche est effectuée sur le second, et ainsi de suite. Cela s’arrêtera si un ou plusieurs éléments sont trouvés ou si tous les sites de la liste ont été utilisés.

L’étape suivante dépend du nombre de résultats.

S’il y en a un seul, les champs présent sur le site sont automatiquement remplis dans GCstar Si en revanche plusieurs existent, une liste apparaît permettant de faire son choix.

Liste de résultats

En cliquant sur le titre d’une des colonnes, les résultats sont triés selon celle-ci afin de plus facilement trouver celui qui est recherché.

Double-cliquer sur un résultat ou le sélectionner puis cliquer sur Valider provoquera le même résultat : Les informations seront récupérées.

Enfin, si rien n’est trouvé, vous aurez la possibilité de lancer la recherche sur un autre site.

Par défaut toutes les informations récupérées sont ensuite mises dans les champs correspondants de sa fiche. Mais comme ce sera expliqué dans le chapitre Internet, une option permet de changer cela. Si on choisit de Choisir les champs à importer, une fenêtre intermédiaire apparaît.

Sélection des champs à importer

Les images peuvent également être affichées, s’il y en a, au moyen des boutons Voir l’image.

Il existe un autre moyen pour ajouter un élément dans une collection. Si vous être sur un des sites gérés par ce logiciel en train de consulter une fiche, vous pouvez directement l’intégrer dans GCstar. Pour cela, faites glisser depuis la barre d’adresse de votre navigateur l’élément correspondant à l’URL. Déposez le sur GCstar et la fiche sera ajoutée automatiquement. Dans la plupart des navigateurs, l’élément qu’il faudra faire glisser est une petite icône à l’effigie du site. Par exemple :

Barre d'adresse d'un navigateur

Gérer plusieurs collections

GCstar permet de gérer plusieurs collections de différents types. Pour chacune, un fichier sera enregistré. Cela se passe dans le menu Fichier.

Menu Fichier

Choisir Nouveau permet de créer une nouvelle collection. Le type de collection sera demandé à l’utilisateur.

Choix du type de collection

Il y a plus d’informations sur les collections personnelles dans la page Création de modèles personnalisés

Enregistrer sous permet de choisir un autre fichier pour sauvegarder la liste. C’est nécessaire pour une nouvelle liste créée, mais peut aussi permettre de dupliquer une liste.

Enfin l’élément Ouvrir, sert à charger une collection précédemment sauvegardée.

Au lancement, GCstar ouvre automatiquement la dernière collection ouverte avant de quitter l’application. Mais le sous-menu Fichiers récemment ouverts permet d’avoir rapidement accès aux autres fichiers consultés ou modifiés.

Verrouillage de collection

Un utilisateur peut verrouiller une collection. Cela se fait par la case à cocher correspondante dans le menu Edition.

Quand une collection est verrouillée, les informations ne peuvent plus être changées. Cela permet d’éviter des modifications non souhaitées. Pour déverrouiller la collection, il suffit de décocher la case.

Une collection est également automatiquement déverrouillée quand un nouvel élément est ajouté.

 
fr/collections_management.txt · Dernière modification: 30/09/2009 08:45 par 62.203.214.40



Si avez rencontré un problème avec GCstar, vous pouvez ouvrir un rapport de bug ou demander de l'aide sur les forums GCstar.